Windows 平台安装 node-gyp 报错

远子 •  2020年06月01日

报错信息如下:

npm ERR! Failed at the <package>@<version> install script 'node-gyp rebuild'
...
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.

这是因为需要在本地安装 node-gyp, 这个包依赖于 python 2.7 和一些其他组件, 解决方案:

npm install --global --production windows-build-tools

重新安装依赖即可.

(完)